Bienvenue sur le forum des portables Asus !
Une communauté d'utilisateurs, des conseils d'experts, des guides et des tutos pour réparer vous même votre portable.

Arrivé en limite du "Do It Yourself" ? Nous prenons en charge votre portable dans nos ateliers.

Je rejoins la communauté Asus

EN COURS Boot sur une carte SD

Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#1
Bonjour tout le monde,

Comme dit dans mon précédent poste, j'ai pour projet de faire tourner en dual boot windows10 et Android sur mon pc Asus transformer T300LA. Je prépare donc là ma carte micro SD (si j'arrive au bout j'expliquerais comment j'ai fait ^^). Donc ma micro carte SD est prête avec Android 5.1 et Grub d'installer dessus. Je teste sur un autre pc portable tout va bien. Mais (il faut toujours un mais :) ) Je n'arrive pas boot sur la carte SD sur la tablette! Je m'explique :

J'ai bien suivis le tuto pour afficher les listes des périphériques bootables. Désactivation du "Sécure Boot Menu" > Désactivation du "Fast Boot" > activation du "Launch CSM" et effectivement je peux régler mon boot entre Windows et la clef USB mais malheureusement pas de signe du lecteur de carte SD. Le problème n'est pas du tout lié a Android mais plus a la tablette. Si quelqu'un a eu le même problème en installent Ubuntu sur une carte SD et qu'il a la solution je suis preneur, car c'est l'avant dernière étape avant de finir mon petit projet:cry:
 

Donald

Membre Premium
Modèle
N550JV-CM230H-N56VZ-S4263H
Proc
I7 4700HQ - I7 3630QM
HD
OCZ Vertex3 120GO - IDEM
RAM
2x8GO - 2x4GO 1600mhz
Ecran
15.6" 1920x1080
OS
WINDOWS 10 - WINDOWS 8.1
#2
Salut keto14,

C'est comme une clé USB, il te faut la rendre bootable ta carte micro SD !
Tapes sur Google : créer une carte micro sd bootable

Tu as des utilitaires, pour rendre ta carte bootable.

Salutationa et bonne année 2016 donald....
 
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#3
No, no, no.

Comme dit plus haut la carte SD fonctionne parfaitement, je l'ai testé sur 2 autre pc, tout fonctionne bien. De plus je parle de l'affichage dans le bios même si le périphérique n'est pas bootable, normalement il apparaît dans la liste du bios si il a bien était branché avant le démarrage de celui-ci. Mais là non.
 

kankan

Staff
Barreur
Modèle
Pro B8430UA-FA0412E / G75VW
Vendeur
materiel.net
Achat
2016 / 2012
Proc
i7-6500U 2,5 GHz / i7-3610QM
HD
SSD
RAM
8 Go DDR4 / 16 Go DDR3
Ecran
2 Ecrans 27' Asus VG278HE
OS
Windows 10
#4
Bonjour à tous,
keto14 keto14 : quel est le processeur sur ton portable : Intel ATOM ?
 

kankan

Staff
Barreur
Modèle
Pro B8430UA-FA0412E / G75VW
Vendeur
materiel.net
Achat
2016 / 2012
Proc
i7-6500U 2,5 GHz / i7-3610QM
HD
SSD
RAM
8 Go DDR4 / 16 Go DDR3
Ecran
2 Ecrans 27' Asus VG278HE
OS
Windows 10
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#7
Effectivement il m'affiche une liste mais la carte SD n'est pas présente :S
 

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#8
Bonjour à tous,

@Keto: Ton sujet m'a interpellé, j'ai testé cette nuit une installation sur une clé USB de mon ordinateur, via une clé "liveCD". MOn post ne va sûrement pas t'aider, mais au minimum ca laissera une trace pour ne pas que j'oublie les manipulations que j'ai faite.

La configuration de mon ordinateur:
i7
UEFI en version 64 bits, possibilité d'activer le mode CSM.



pour ceux qui lisent ce posts, il faut éviter de faire ce test sur des machines sont le firmware UEFI est bugué, comme le modèles G (les rogs) .

J'ai testé sur machine virtuelle et sur mon ordinateur une version testing d'android, provenant de ce site.

https://www.android-x86.org/

La version que j'ai testé cette nuit , la android-x86-6.0-20151202.iso, disponible via le lien ci-dessous:

https://sourceforge.net/projects/android-x86/files/Testing/

Le but étant d'installer cette version d'android sur une autre clé USB.
Il y a donc une clé pour graver l'ISO via rufus, et une autre clé vierge pour installer android sur cette clé.

Première étape:graver androidx86 sur une clé USB:

J'ai gravé l'ISO via rufus, j'ai choisi l'option MBR pour MBR ou SCM-UEFI.
En redémarrant l'ordinateur, j'active le mode legacy (CSM) et lors du démarrage, (touche "echap"), et je choisis le nom de la clé (sans le terme UEFI).

Ca démarre, je peux tester le mode "liveCD", et ca fonctionne très bien.
Android sur ordinateur est vraiment une tuerie, comparé à un téléphone, bien que je n'aime pas cet OS, puisque non respectueuse de la vie privée.

Seconde étape: Installer android sur une seconde clé USB:

Après de multiples tests, j'ai converti la clé USB en table de partition GpT, (avec gparted).
Lors de la création de la clé USB dite "bootable", en partition manuelle, j'ai testé de multiples configuration pour essayer de démarrer, je suis arrivé à avoir le grub au démarrage (en démarrant sur "UEFI:nom_de_la_clé_bootable").
Malgré cela, ma clé utilise une table de partition MBR, je crois bien que j'ai converti la clé "bootable" en utilisant une table de partition MBR. J'ai crée dans le mode de partition manuel une partition primaire , et je j'ai ajouté le drapeau "bootable".

Finalement, je suis arrivé à avoir le grub au démarrage (en démarrant sur "UEFI:nom_de_la_clé_bootable").
J'ai accès à un démarrage du grub, dans lequel je dois choisir le mode normal ou le mode rescue.
Mais à partir de là, écran noir... (problème avec la mémoire ?)

Il y a quelque chose qui coince, mais l'installation en mode manuel est une horreur, via le "liveCD", il y a une incohérence avec l'arborescence ci-dessous et la tablé de partition MBR , sur la clé USB où je veux installer Android.

Si ca peut t'intéresser, voici l'arborescence de ma clé "bootable":
.
./.Trash-1000
./.Trash-1000/info
./.Trash-1000/info/bootx64.efi.trashinfo
./.Trash-1000/info/bootia32.efi.trashinfo
./.Trash-1000/files
./efi
./efi/boot
./efi/boot/bootx64.efi
./efi/boot/bootia32.efi
./efi/boot/grub.cfg
./android-6.0-rc1
./android-6.0-rc1/initrd.img
./android-6.0-rc1/kernel
./android-6.0-rc1/system.img
./android-6.0-rc1/data.img
./android-6.0-rc1/ramdisk.img


Au final, je me demande si le problème ne provient pas du fait que android utilise une architecture 32 bits, alors que mon UEFI ne reconnaît que les OS en 64 bits.
Étant donné que la version que j'ai testé est une version testing, ce n'est pas stable.Je ferai des tests dans le futur, j'essayerai de copier les fichiers listé ci-dessus sur ma clé avec une table de partition GpT au lieu de MBR ou de faire d'autres tests.
Il y a beaucoup d'incohérences lors de l'installation manuelle, il faut plus d'investigation.

Le processus de démarrage de l'ISO x86 d'android étant différent des OS dur PC, je dois obtenir plus de renseignements, ca va prendre du temps.


Cordialement.
 
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#9
Merci de ta réponse alexendre01, j'ai fait à peu près la même chose à quelque différence près.

J'ai commencé par test une version live via une clé USB sur ce pc et cela fonctionne bien.

Le site que tu as fournis est effectivement le site officiel du "portage" de Android sur un pc Intel cependant j'ai choisi la version 5.1 car plus stable ^^.

J'ai créé l’installateur bootable via Lili USB creator, mais cela ne doit pas changer grand-chose ^^.

J'ai fait l'installation sur la carte SD depuis l'installateur USB sur un autre pc (un pc cobaye au cas où je fais une connerie). Par contre je note une différence pour l'arborescence par rapport à toi :


.
./efi
./efi/boot
./efi/boot/bootx64.efi
./efi/boot/bootia32.efi
./efi/boot/grub.cfg

./grub
./grub/android-x86.xpm.gz
./grub/device.map
./grub/e2fs_stage1_5
./grub/fat_stage1_5
./grub/menu.lst
./grub/ntfs_stage1_5
./grub/stage1
./grub/stage2
./grub/stage2_eltorito
./android-5.1-rc1
./android-5.1-rc1/initrd.img
./android-5.1-rc1/kernel
./android-5.1-rc1/system.img
./android-5.1-rc1/data.img
./android-5.1-rc1/ramdisk.img

./android-5.1-rc1/system.sfs

Cette carte SD fonctionne sur 2 autre pc, par contre je ne peux être précis sur le bios car j’ai peu de connaissance dans ce domaine. La seul chose que je peux dire c'est que 1 des pc a un bios sous le vieux format (navigation uniquement par clavier) et l'autre plus récent (navigation clavier ou souris).
 

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#10
Re keto14,

Le site que tu as fournis est effectivement le site officiel du "portage" de Android sur un pc Intel cependant j'ai choisi la version 5.1 car plus stable ^^.
Je testerai sur la version 5.1. En effet, comme tu l'indiques, c'est une version stable et probablement il y aura plus de chance de réussite.

J'ai créé l’installateur bootable via Lili USB creator, mais cela ne doit pas changer grand-chose ^^.
Pas sûr. Quand j'avais commencé des tests concernant pour comprendre l'installation de L'UEFI, LiliUSBcreator ne m'a été aucune utilité.
Rufus est plus flexible pour des OS avec UEFI, même pour les distributions linux , ce que lili ne fait pas.

C'est vrai que Rufus n'existe que sur Windows, c'est le seul point négatif. Heureusement que les hyperviseurs existent.

J'ai fait l'installation sur la carte SD depuis l'installateur USB sur un autre pc (un pc cobaye au cas où je fais une connerie).
C'est vrai que c'est dangereux, surtout que je n'ai pas d'ordinateur en UEFI de réserve. La seconde clé USB pour installer cet OS m'a été d'un grand secours.

Par contre je note une différence pour l'arborescence par rapport à toi :
==>C'est possible si tu peux afficher le contenu du fichier ./efi/boot/grub.cfg ?

La seul chose que je peux dire c'est que 1 des pc a un bios sous le vieux format (n'navigation uniquement par clavier) et l'autre plus récent (navigation clavier ou souris).
J'avais testé sous machine virtuelle l'android en question. C'est horrible par le clavier , et ca bugait quand je voulais passer l'étape pour lister les hostops Wifi.

Ceci étant dit:

Cette carte SD fonctionne sur 2 autre pc, par contre je ne peux être précis sur le bios car j’ai peu de connaissance dans ce domaine. La seul chose que je peux dire c'est que 1 des pc a un bios sous le vieux format (n'navigation uniquement par clavier)
Il est vrai que le terme UEFI est anbigue, et les constructeurs maintiennent cette anbuguité, soit par ignorance, soit en le faisant exprès pour ne pas choquer les utilisateurs habitués au bios.

L'UEFI est le remplaçant du firmware bios, avec l'ajout d'une interface conviviale pour l'utilisateur. Sur les ordinateurs portables asus, cela ne se voit pas trop, puisque l'interface ressemble à celle d'un bios.

==>L'UEFI (je parle de la version 2.3.1) utilise une table de partition GpT (ou GUID partition Table) tandis que le bios utilise une table de partition MBR.

Attention: Ne pas confondre table de partition et système de fichiers.
Un système de fichiers tel que fat32, ext4, peut être lu par un OS étant installé sur un ordinateur utilisant une table de partition GpT que sur un ordinateur utilisant une table de partition MBR.


On ne parlera pas des bénéfices de la table de partition GpT au lieu de la table de partition MBR, mais il faut savoir que:

==>Pour les UEFI, la seule table de partition par défaut reconnue est la table de partition GpT. Pour pouvoir démarrer un OS prenant en charge l'UEFI, il faut une petite partition bootable pour pouvoir démarrer l'ordinateur, appelé ESP (Efi System Partition) au lieu de l'ancêtre MBR ==> A vérifier.

Concrètement, c'est la partition EFI (utilisant un drapeau "boot" et "esp"), utilisant un système de fichier FAT32, sur Windows, auquel sont enregistrés les fichiers de démarrage de Windows pour pouvoir démarrer Windows. Une des caractéristiques sous Windows est qu'il faut au minimum le fichier situé dans /EFI/BOOT/bootx64.efi

Même chose pour debian, il existe une partition EFI avec les mêmes caractéristiques, la différence est qu' il faut au minimum un fichier /EFI/BOOT/grubx64.efi pour pouvoir démarrer.

Tout ceci pour dire que dire que le firmware UEFI ne sait que lire les partitions utilisant un système de fichier de type FAT (Fat32 est utilisé la plupart des fois).

Note:Attention, jusqu'à preuve du contraire, un firmware UEFI en64 bits ne peut lire que des OS 64 bits et un UEFI en 32 bits ne peut lire que des OS 32 bits.
C'est une affirmation gratuite, je ne crois pas que les firmwares UEFI sont en 32 bits ou 64 bits, donc maintenant je suis plus réservé sur cette affirmation. Mais en considérant si c'est vrai, si tu utilises un firmware 32 bits; tu auras à la place de /EFI/grubx64.efi , tu auras /efi/grubia32.efi et pour windows, à la place de
/EFI/BOOT/bootx64.efi ce sera /EFI/BOOT/bootia32.efi



==>Tandis que les ordinateurs ayant un bios (utilisant donc une table de partition MBR) peuvent reconnaître au boot (par exemple un système de fichiers NTFS, iun firmware UEFI ne lit pas le NTFS

==>Enfin, le mode CSM prend en charge la compatibilité de certaines interruptions du bios, mais j'expliquerai cela si ca t'intéresse , pour ne pas alourdir la discussion.


J'espère que j'ai été clair, c'est pas simple à comprendre au début.

Pour ma part, le fait que ta clé USB ne soit pas reconnue sut ton T300, c'est que cette tablette utilise un firmware UEFI et que ta clé utilise un système de fichier NTFS.
En testant sur d'autres ordinateurs ayant un bios, ta clé est lisible.


==>Tu confirmes ?

Le windows sur ta tablette, est une version 32 bits ou 64 bits ?

Cordialement
 
Dernière édition:
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#11
Merci pour toute ces explications, j'en ai beaucoup appris, pour les point ou tu a des doute je ne suis pas la bonne personne pour les dissiper ^^

==>C'est possible si tu peux afficher le contenu du fichier ./efi/boot/grub.cfg ?
Si tu veut le contenue de ce fichier :

Code:
set timeout=6
set gfxmode=1024x768
terminal_output gfxterm
 
 
menuentry "Android-x86 5.1-rc1" {
search --set=root --file /android-5.1-rc1/kernel
linuxefi /android-5.1-rc1/kernel quiet root=/dev/ram0 androidboot.hardware=android_x86 
initrdefi /android-5.1-rc1/initrd.img
}
menuentry "Android-x86 5.1-rc1 (DEBUG mode)" {
search --set=root --file /android-5.1-rc1/kernel
linuxefi /android-5.1-rc1/kernel root=/dev/ram0 androidboot.hardware=android_x86  DEBUG=2
initrdefi /android-5.1-rc1/initrd.img
}
Pour ma part, le fait que ta clé USB ne soit pas reconnue sut ton T300, c'est que cette tablette utilise un firmware UEFI et que ta clé utilise un système de fichier NTFS.
En testant sur d'autres ordinateurs ayant un bios, ta clé est lisible.


==>Tu confirmes ?
Donc,

La clef USB ne possède que l’installeur, mon installation est faite sur une carte SD. Les 2 pc où elle fonctionne sont :

Pc portable : easynote tm86-jn-218fr lien magasin : Materiel.net
Pc fixe (je mets juste la carte mère) : asus rog maximus formula V lien constructeur : ASUS

Ma clef USB (qui contient l'installateur) est en Fat32 et je viens de tester, la tablette peut boot dessus.
Ma carte SD (qui contient l'installation) est en Fat32.

Personnellement je pense que mon problème vient juste du faite que le bios de cette tablette contrairement à d'autre bios, n'accepte pas de boot sur une carte SD. Le top serais que je fasse une installation sur une clef USB pour confirmer ce que je viens de dire. Mais si cela est le cas, cela serais très contraignant car cette tablette ne possède qu'une seul prise USB et donc à l’usage j'en n'aurais pas en resserve :s
 

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#12
Re keto14,

Pc portable : easynote tm86-jn-218fr lien magasin : Materiel.net
Pc fixe (je mets juste la carte mère) : asus rog maximus formula V lien constructeur : ASUS
Concernant la carte mère, quasi-sûr que c'est un UEFI comme firmware.
Concernant le pc easynote, je ne sais pas, je pense plutôt à un bios, mais à confirmer.

Toutefois, comme tu l'indiques, ca ressemble plutôt à un problème de T300.

En regardant cette page:
https://wiki.debian.org/UEFI#Support_for_mixed-mode_systems:_64-bit_system_with_32-bit_UEFI

Les intels atoms semblent être un cas à part:

debian a dit:
Some systems have been released containing 64-bit Intel Atom CPUs (such as the Bay Trail), but crippled with 32-bit UEFI firmware with no BIOS compatibility mode. Using the 32-bit UEFI x86 support, an i386 installation should be possible on these machines but it won't make the most of the 64-bit hardware.
Je traduis:

Certains systèmes ont été fournis avec un processeur intel atom 64 bits, mais pose problème avec des firmwares UEFI 32 bits sans le mode de compatibilité (dixit: "Le mode CSM , encore appelé mode legacy).
En utilisant un support UEFI 32 bits avec jeux d'instructions x86, une installation avec un DVD asus i386 doit-être possible sur ces machines, mais la plupart des fonctionnalités matérielles ne sera pas supportés.

==> Je ne sais pas si l'OS installé sur ta tablette est un OS 32 bits ou 64 bits. Peux-tu me le préciser ?
Je te conseillerai de mettre de côté :

./efi/boot/bootx64.efi

pour ne laisser que :

./efi/boot/bootia32.efi


Et inversement pour voir ce que cela donne. Je n'y crois pas trop, mais à essayer.


Enfin, je ne sais pas si tu es sous une distribution GNU\Linux ou sous Windows, pour voir les drapeaux de ta carte SD; Peux-tu me le préciser ?

Pour terminer, un hommage à Ian Murdock, le fondateur de Debian qui est décédé le 28 Décembre 2015...
Dommage...
 
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#13
Ha je savais bien que j'avais oublié une question ^^.

L'OS du T300 est un Windows 10 64bit, je n'ai malheureusement pas de clef USB en surplus, je ferais le test avec une clef USB lundi alors. Pour les fichier.efi je testerais demain :).

Merci encore, bonne soirée et a demain.
 

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#14
Re keto14,


L'OS du T300 est un Windows 10 64bit, je n'ai malheureusement pas de clef USB en surplus, je ferais le test avec une clef USB lundi alors. Pour les fichier.efi je testerais demain :).
Ok, je regarderai si j'ai un moment de mon côté, je vais me pencher sur le contenu de Windows et de Debian quand ces derniers sont bootables, pour voir si je suis la bonne route.


Ha je savais bien que j'avais oublié une question ^^.
Ca arrive ;)

Cordialement
 

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#15
Bonjour à tous,

@ keto14:

J'ai réussi à installer android (la 5.1) sur une clé USB et à la faire démarrer!
Malheureusement, quelques bugs, peut-être à ce système de fichiers fat32, à tester plus tard.

Pour les UEFI 64 bits, il faut prendre la version x86_64:

Le lien est ci-dessous:

https://sourceforge.net/projects/android-x86/files/Release 5.1/android-x86_64-5.1-rc1.img/download

le sha1(pour vérifier que le fichier est identique à celui téléchargé) est:
Code:
56d559d186033a840076d0517ecb89d3c8cc46b5

Sous Windows, tu prends ta clé USB, et tu utilises Rufus pour la graver. (Pas besoin de paramètres, c'est une copie brute).
Pour ta clé USB d'installation, tu devrais avoir une configuration semblable:

android_usb_install-png.2815


Ensuite, pour ta carte SD, tu choisis l'option GpT ou ordinateur UEFI.

android_install_sd-png.2816

Lors de l'installation, en choisissant l'installation graphique, tu ne formates pas la clé, tu installes seulement grub2 pour EFI, tu réponds oui à toutes les questions.

Pour information, je ne comprends pas pourquoi j'ai cette table de partition ci-dessous, il faut que je revois l'installation (j'ai visité l'option de partitionnement de disque, mais je n'ai rien touché, normalement):

Code:
Device	 Start	  End  Sectors  Size Type
/dev/sdc1   2048 62333918 62331871 29,7G Microsoft basic data
 
Disque /dev/sdd : 14,6 GiB, 15631122432 octets, 30529536 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x00000000
Note: la carte SD où j'ai installé android est celle-ci, normalement réservé à mon Raspberry.

Note 2: L'arborecence de la carte SD, où est installé android.

├── android-5.1-rc1
│ ├── data.img
│ ├── initrd.img
│ ├── kernel
│ ├── ramdisk.img
│ └── system.img
├── efi
│ └── boot
│ ├── bootia32.efi
│ ├── bootx64.efi
│ └── grub.cfg
├── LOST.DIR
└── System Volume Information
└── IndexerVolumeGuid

Finalement, sur l'ordinateur, android est vraiment du tonerre, android devrait songer à installer android sur des ordinateurs.

Dans l'avenir ce serait bien qu'android s'impose sur les PC portables, puisque ca pourrait intéresser pas mal d'utilisateurs qui n'ont que des besoins basiques,et est beaucoup plus simple que Windows 10.

De plus, comme Microsoft utilise le même modèle de marché que google, qui consiste à récolter des données, autant utiliser quelque chose de plus simple, et plus ergonomique.


Par contre, il existe des bugues, et le démarrage est ralenti.

Exceptionnellement, je poste une vidéo, après avoir installé quelques programmes, pour montrer ce que cela donne (jeux et navigateurs, ce n'est pas encore tout à fait fiable, ca va me demander un peu de temps pour convertir la vidéo et supprimer le max de métadonnées)

Edit: Via la procédure ci-dessus, ca ne fonctionne qu'avec UEFI (CSM désactivé). En activant CSM, j'ai un écran avec un message d'erreur.

Edit 2: Je poste une vidéo, avec un clin d'oeil à mes copains britanniques.

2353-1451778659-977abc25641ebfc6d98b90ebd9a10416.jpg

android_USB_UEFI_démo
par alexandre01

Edit 3: D'autres tests sont nécessaires, comme création d'une partition EFI pour le démarrage du grub, une autre partition avec un système de fichiers ext4 par exemple .
Cordialement
 
Dernière édition:
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#16
Bon voilà j'ai une 2eme clef, j'ai juste fait un premier test mais je voulais éclaircir un point. J'ai donc installé sur ma clef USB depuis une autre clef USB en suivant exactement la procédure que j'avais faite pour ma carte SD. Pour éviter de changé trop de facteur et donc facilité une conclusion. Donc je fais ma clef, depuis un pc portable avec un BIOS, la clef faite sur le même pc je tente un boot. Nickel la clef est reconnu puis Android boot. Ensuite je mets la clef sur le T300 et l’UEFI ne trouve pas ma clef. Donc tout n'est pas perdu pour boot sur la carte SD. Du coup je vais suivre ta procédure et voir ci cela fonctionne chez moi.
 
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#17
Bon, j'ai suivis la procédure que tu as décrite au-dessus.

Pour la carte SD, elle n’est tout simplement pas affichée dans l'UEFI. Que ce soit directement dedans où en appuyant sur Echap.

Je fais un essai avec une clef USB, là c'est différent. La clef bien présente dans la liste de boot. Quand je la sélectionne grub apparais. Et quand je sélection Android j'ai un écran noir :s
 

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#18
Bonjour keto14,

Pour la carte SD, elle n’est tout simplement pas affichée dans l'UEFI. Que ce soit directement dedans où en appuyant sur Echap.
J' y pense, la carte SD, c'est la grosse carte que tu glisses dans une fente ?
Si c'est le cas, c'est normal,il faut un pilote pour que cela soit reconnu nativement.

Bonne remarque, avec l’avènement des cartes microSD et des adaptateurs, je n'ai pas été assez précis.
Ma remarque peut sembler bête, mais je me suis fait piégé dans le passé.

Je fais un essai avec une clef USB, là c'est différent. La clef bien présente dans la liste de boot. Quand je la sélectionne grub apparais. Et quand je sélection Android j'ai un écran noir :s
J'avais le même souci avec la version x86 de android.
La version x86_64 a résolu le problème, je pense à un problème de mémoire, car la mémoire utilisé pour un bios et un UEFI n'est pas géré de la même façon (mon ordinateur est un UEFI qui gère que les versions 64 bits).

==>Je pense que tu as dû essayer aussi ce que j'avais indiqué précédemment pour la version 32 bits d'android, au cas où ton T300L aurait qu'un firmware ne reconnaissant que les OS 32 bits. Si ce n'est pas le cas, c'est mal parti, il faudra tester d'autres manipulations


Cordialement
 
Modèle
T300LA-C4040H
Achat
27/11/2015
Proc
I3
HD
SSD 64 go
RAM
4G
Ecran
1920x1080
OS
W8.1
#19
J' y pense, la carte SD, c'est la grosse carte que tu glisses dans une fente ?
Oui, oui c'est bien la micro carte SD que j'insère directement dans la tablette.


Bon je viens de recevoir la réponse du support ASUS pour le boot sur carte SD :

Bonjour Monsieur ********,

Nous vous remercions d'avoir sollicité le support technique d’ASUS.

A la lecture de votre E-mail, je note que vous voulez démarrer votre PC sur la carte micro SD afin d'installer le système Linux .

En vérifiant l'information auprès de la cellule d'expetise, je vous informe, Monsieur ********, que le PC ne peut pas booter sur le lecteur des cartes SD. Il vaut mieux utiliser un périphérique USB ou micro USB.

En vous souhaitant bonne réception, je me tiens à votre disposition pour de plus amples renseignements et je vous souhaite une bonne journée.

Nadhem, de l’équipe des conseillers ASUS
SAV Asus France
Hotline : 01 70 94 94 00
Assistance officielle | ASUS France
Bon je pense que je peux abandonner le boot sur la carte SD. Je n'ai qu'une seul prise USB, qui va donc être sacrifier pour Android. Je viens de commander ça :

Sandisk Ultra Fit USB 3.0 Flash Drive 64 Go

Du fin pour ne pas être gêné. Pour mon problème de boot USB j'avance bien. Mais Android est tréééééééééééééééééés lent. je pense que m'a clef cadeau de 2go est pas suffisant pour faire les essai. Je vais attendre patiemment celle de Darty.

Pour réussir a boot je suis retourné sur "android-x86-5.1-rc1.iso" et je boot sur la clef installé PAS en UEFI, c'est a plus rien y comprendre mais j'arrive sur Android au moins ^^.

J'ai fait un très rapide tour sur les périphériques :

Le clavier et pavé tactile : fonctionne
L'écran tactile : fonctionne
Le Wifi : fonctionne
Le Bluetooth : ne fonctionne pas
Le bouton "Windows" de la tablette : fonctionne
Les boutons volume de la tablette : fonctionne
Le bouton off de la tablette : fonctionne (ne propose que de l'éteindre)
Le son : fonctionne
La caméra avant/arrière : fonctionne
Le GPS :

Le pc a planté ^^. Bon je vais attendre une "vrai" clef USB pour faire de vrai essai ^^
 
Dernière édition:

alexandre01

Staff
Modérateur
Modèle
asus s550cm\asus x750 UDR
Vendeur
darty\amazon
Achat
fin 2013\fin 2017
Proc
i7 3ème génération\I7 8ème génération
HD
1To disque7200 trs\ 1To disque dur 5400 trs+ssd 250 Go
RAM
16 go DDR3\16 Go DDR4
Ecran
1366*768\1920*1080
OS
Manjaro
#20
Bonjour keto14,

Du fin pour ne pas être gêné. Pour mon problème de boot USB j'avance bien. Mais Android est tréééééééééééééééééés lent. je pense que m'a clef cadeau de 2go est pas suffisant pour faire les essai. Je vais attendre patiemment celle de Darty.
C'est vrai que ma carte SD est de classe 10, donc très rapide en écriture\lecture, c'est peut-être pour cela qu'android n'est pas lent.
Bizarre que l'on obtient pas les mêmes choses, sûrement dû que tu as une tablette T300.

Plus tard, je vais essayer de faire un dualboot, quand je réinstallerais Debian.


Pour réussir a boot je suis retourné sur "android-x86-5.1-rc1.iso" et je boot sur la clef installé PAS en UEFI, c'est a plus rien y comprendre mais j'arrive sur Android au moins ^^.
Ce serait intéressant d'indiquer ce que tu as effectué lors de l'installation(type de partition, grub installé ou grub2, partitionnement), version x86 ou version x86_64.
De fournir aussi l'arborescence de ton média d'installation, ce serait intéresant.

Le pc a planté ^^. Bon je vais attendre une "vrai" clef USB pour faire de vrai essai ^^
Moi aussi ca pante, ce n'est pas stable.

COrdialement
 

Sujets similaires

Vos accessoires ASUS

  L'atelier ASUS : témoignages

Nous vous aidons ... aidez nous.

Soutenir les forums Asus

Pour continuer à recevoir un support de qualité et gratuit dans les forums, aidez nous a supporter le coût de notre infrastructure.
Objectif
120.00 €
Collecté
30.00 €
Cette campagne s'achève dans

Parcourir les forums en musique